Network Bond/Team Problem

UNIX/Linux Network Administration - Rich Simms
Locked
User avatar
Jack Hsieh
Posts: 60
Joined: Tue Feb 09, 2010 5:53 pm

Network Bond/Team Problem

Post by Jack Hsieh » Sun May 23, 2010 8:11 pm

Been trying to get network bond/teaming working but the only way it will work is with dhcp. When I assign static IP it just won't work.

This is on CentOS 5.5

[root@ ~]$ cat /etc/sysconfig/network
NETWORKING=yes
NETWORKING_IPV6=no
HOSTNAME=
GATEWAY=192.168.1.1

[root@ ~]$ cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]
DEVICE=eth0
HRADDR=
BOOTPROTO=none
ONBOOT=yes
USERCTL=no
MASTER=bond0
SLAVE=yes

[root@ ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth1
# Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]
DEVICE=eth1
BOOTPROTO=none
ONBOOT=yes
USERCTL=no
MASTER=bond0
SLAVE=yes

[root@ ~]$ cat /etc/sysconfig/network-scripts/ifcfg-bond0
DEVICE=bond0
HWADDR=
USERCTL=no
BOOTPROTO=static
ONBOOT=yes
IPADDR=192.168.1.200
NETMASK=255.255.255.0

[root@ ~]# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 bond0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 bond0
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 bond0

User avatar
Rich Simms
Posts: 2421
Joined: Sat Jan 16, 2010 5:47 pm
Contact:

Re: Network Bond/Team Problem

Post by Rich Simms » Wed May 26, 2010 4:34 pm

I tried some slightly different settings I found at http://www.howtoforge.com/network_card_bonding_centos and they worked.

Here is the configuration I used:

Code: Select all

[root@jack ~]# head /etc/sysconfig/network-scripts/ifcfg-[eb]*
==> /etc/sysconfig/network-scripts/ifcfg-bond0 <==
DEVICE=bond0
IPADDR=192.168.2.111
NETMASK=255.255.255.0
ONBOOT=yes
BOOTPROTO=none
USERCTL=no

==> /etc/sysconfig/network-scripts/ifcfg-eth0 <==
# Intel Corporation 82543GC Gigabit Ethernet Controller (Copper)
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=none
USERCTL=no
MASTER=bond0
SLAVE=yes

==> /etc/sysconfig/network-scripts/ifcfg-eth1 <==
# Intel Corporation 82543GC Gigabit Ethernet Controller (Copper)
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=none
USERCTL=no
MASTER=bond0
SLAVE=yes
[root@jack ~]# 
Here is the result:

Code: Select all

[root@jack ~]# ifconfig
bond0     Link encap:Ethernet  HWaddr 08:00:27:5F:41:97  
          inet addr:192.168.2.111  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fe5f:4197/64 Scope:Link
          UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1
          RX packets:6315 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7980 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:604546 (590.3 KiB)  TX bytes:596530 (582.5 KiB)

eth0      Link encap:Ethernet  HWaddr 08:00:27:5F:41:97  
          UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
          RX packets:6092 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3677 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:589678 (575.8 KiB)  TX bytes:267508 (261.2 KiB)
          Memory:f0000000-f0020000 

eth1      Link encap:Ethernet  HWaddr 08:00:27:B1:69:DC  
          UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
          RX packets:223 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4303 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:14868 (14.5 KiB)  TX bytes:329022 (321.3 KiB)
          Memory:f0820000-f0840000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:891 errors:0 dropped:0 overruns:0 frame:0
          TX packets:891 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:63948 (62.4 KiB)  TX bytes:63948 (62.4 KiB)

[root@jack ~]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 bond0
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 bond0
0.0.0.0         192.168.2.1     0.0.0.0         UG    0      0        0 bond0
[root@jack ~]# ping -c2 192.168.2.1
PING 192.168.2.1 (192.168.2.1) 56(84) bytes of data.
64 bytes from 192.168.2.1: icmp_seq=1 ttl=64 time=0.000 ms
64 bytes from 192.168.2.1: icmp_seq=2 ttl=64 time=1.85 ms

--- 192.168.2.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1014ms
rtt min/avg/max/mdev = 0.000/0.928/1.857/0.929 ms
[root@jack ~]# 
- Rich

Kay Lee
Posts: 50
Joined: Tue Feb 09, 2010 5:53 pm

Re: Network Bond/Team Problem

Post by Kay Lee » Thu May 27, 2010 5:56 pm

Good to know, Good information. :D

Locked

Return to “CIS 192AB - Spring 2010”