Issues with Hershey - Port 110

UNIX/Linux Network Administration - Rich Simms
Evan Norbom
Posts: 10
Joined: Mon Sep 03, 2012 11:55 pm

Issues with Hershey - Port 110

Post by Evan Norbom » Mon May 13, 2013 12:48 pm

I can't seem to connect to Hershey via telnet or fetchmail over port 110.

SSH works fine, but I can't telnet to port 110 via localhost either.

Error messages:
fetchmail
fetchmail: connection to hershey:pop3 [172.30.5.17/110] failed: Connection refused.
POP3 connection to hershey failed: Connection refused
fetchmail: Query status=2 (SOCKET)

telnet hershey 110
Trying 172.30.5.17...
telnet: connect to address 172.30.5.17: Connection refused

telnet hershey 110
Trying 127.0.0.1...
telnet: connect to address 127.0.0.1: Connection refused
telnet: Unable to connect to remote host: Connection refused

adam ryszka
Posts: 50
Joined: Thu Feb 14, 2013 10:30 am

Re: Issues with Hershey - Port 110

Post by adam ryszka » Mon May 13, 2013 1:51 pm

Evan Norbom wrote: Error messages:
fetchmail
fetchmail: connection to hershey:pop3 [172.30.5.17/110] failed: Connection refused.
POP3 connection to hershey failed: Connection refused
fetchmail: Query status=2 (SOCKET)

telnet hershey 110
Trying 172.30.5.17...
telnet: connect to address 172.30.5.17: Connection refused
I am getting these as well...

User avatar
Rich Simms
Posts: 2421
Joined: Sat Jan 16, 2010 5:47 pm
Contact:

Re: Issues with Hershey - Port 110

Post by Rich Simms » Mon May 13, 2013 5:56 pm

OOPS ... was me messing with Hershey today. It will work now.

- Rich

adam ryszka
Posts: 50
Joined: Thu Feb 14, 2013 10:30 am

Re: Issues with Hershey - Port 110

Post by adam ryszka » Mon May 13, 2013 6:04 pm

OK seems to be working now. Thanks.

User avatar
Rich Simms
Posts: 2421
Joined: Sat Jan 16, 2010 5:47 pm
Contact:

Re: Issues with Hershey - Port 110

Post by Rich Simms » Mon May 13, 2013 6:07 pm

Sorry guys! I rebooted Hershey this morning. I haven't used it quite awhile and didn't realize dovecot wasn't configured to start at boot. Dovecot provides the imap and pop service.

- Rich

Evan Norbom
Posts: 10
Joined: Mon Sep 03, 2012 11:55 pm

Re: Issues with Hershey - Port 110

Post by Evan Norbom » Mon May 13, 2013 7:13 pm

No worries! Thanks!

adam ryszka
Posts: 50
Joined: Thu Feb 14, 2013 10:30 am

Re: Issues with Hershey - Port 110

Post by adam ryszka » Mon May 13, 2013 8:02 pm

OK one new issue, obviously might be on my side. When running fetchmail I get this error message mixed in with everything else: "fetchmail: connection to localhost:smtp [::1/25] failed: Connection refused." Below is the full output. Feedback appreciated!

fetchmail: Server certificate verification error: self signed certificate
fetchmail: This means that the root signing certificate (issued for /OU=IMAP server/CN=imap.example.com/emailAddress=postmaster@example.com) is not in the trusted CA certificate locations, or that c_rehash needs to be run on the certificate directory. For details, please see the documentation of --sslcertpath and --sslcertfile in the manual page.
fetchmail: Warning: the connection is insecure, continuing anyways. (Better use --sslcertck!)
9 messages for rysada192 at hershey (17584 octets).
fetchmail: connection to localhost:smtp [::1/25] failed: Connection refused.
reading message rysada192@hershey.cislab.net:1 of 9 (2072 octets) not flushed
reading message rysada192@hershey.cislab.net:2 of 9 (2075 octets) not flushed
reading message rysada192@hershey.cislab.net:3 of 9 (2072 octets) not flushed
reading message rysada192@hershey.cislab.net:4 of 9 (2075 octets) not flushed

User avatar
Rich Simms
Posts: 2421
Joined: Sat Jan 16, 2010 5:47 pm
Contact:

Re: Issues with Hershey - Port 110

Post by Rich Simms » Tue May 14, 2013 8:06 am

Try to manually connect to port 25 with telnet localhost 25. If that doesn't work then check that sendmail is running with service sendmail status and review the firewall (make sure you still have the loopback rule that allows everything).

Also, "not flushed" in English means "the message on the remote mail server was not deleted"

- Rich

adam ryszka
Posts: 50
Joined: Thu Feb 14, 2013 10:30 am

Re: Issues with Hershey - Port 110

Post by adam ryszka » Tue May 14, 2013 11:50 am

Still getting the same error and I have spent the better half of this morning working on it. I am hoping it is something simple that I am just over looking. I checked and sendmail is installed and running. I also reviewed the lecture slides for installing and configuring it. Below are my firewall settings and what happens when I Telnet in. You will see with Telnet it cannot connect on the IP but can on the name "localhost". At this point I am out of things to try.

# Generated by iptables-save v1.4.7 on Tue May 14 11:35:54 2013
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [665:105062]
-A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
-A INPUT -p icmp -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -p tcp -m state --state NEW -m tcp --dport 901 -j ACCEPT
-A INPUT -p tcp -m state --state NEW -m tcp --dport 25 -j ACCEPT
-A INPUT -p tcp -m state --state NEW -m tcp --dport 445 -j ACCEPT
-A INPUT -p tcp -m state --state NEW -m tcp --dport 139 -j ACCEPT
-A INPUT -p udp -m state --state NEW -m udp --dport 138 -j ACCEPT
-A INPUT -p udp -m state --state NEW -m udp --dport 137 -j ACCEPT
-A INPUT -p tcp -m state --state NEW -m tcp --dport 22 -j ACCEPT
-A INPUT -j REJECT --reject-with icmp-host-prohibited
COMMIT
# Completed on Tue May 14 11:35:54 2013
REJECT all -- 0.0.0.0/0 0.0.0.0/0 reject-with icmp-host-prohibited


Trying ::1...
telnet: connect to address ::1: Connection refused
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 p21-elrond.rivendell ESMTP Sendmail 8.14.4/8.14.4; Tue, 14 May 2013 11:30:57 -0700

User avatar
Rich Simms
Posts: 2421
Joined: Sat Jan 16, 2010 5:47 pm
Contact:

Re: Issues with Hershey - Port 110

Post by Rich Simms » Tue May 14, 2013 2:56 pm

Try these two experiments:

Hypothesis 1: It is working, just not downloading emails that were previouslyu downloaded
1) Check mail on Elrond using mail command
2) On Opus send yourself some new emails with send-lab09-emails
3) On Elrond, run fetchmail again
4) On Elrond, check your mail again using mail command for new emails

Hypothesis 2: That last line in your firewall is causing problems
1) Disable firewall with service iptables stop
2) Check mail on Elrond using mail command
3) On Opus send yourself some new emails with send-lab09-emails
4) On Elrond, run fetchmail again
5) On Elrond, check your mail again using mail command for new emails

- Rich

Locked

Return to “CIS 192 - Spring 2013”